Opens in a new tab
Open Nav
Sign Up

Vulnerability in RSS Aggregator by Feedzy Plugin (CVE-2024-1317)

Bar Refael

February 21, 2024

A critical vulnerability has been identified in the RSS Aggregator by Feedzy plugin for WordPress, affecting versions up to 4.4.2. The plugin, which has over 50,000 active installations, is widely used for feed to post conversions, import capabilities, and RSS feed displays.

Vulnerability Details:

  • CVE ID: CVE-2024-1317
  • CVSS Score: 8.8 (High)
  • Affected Versions: Up to and including 4.4.2
  • Impact: SQL Injection, Data Exfiltration

Description:

The vulnerability arises from inadequate escaping of user-supplied parameters and insufficient preparation in SQL queries. Specifically, the search_key parameter in the plugin’s fetch_custom_fields() function is vulnerable, allowing authenticated attackers with contributor-level permissions or higher to inject malicious SQL and extract sensitive data, including password hashes.

The flaw is attributed to the misuse of the wpdb->prepare() function and the direct appending of the $like value to the query, bypassing critical defense mechanisms against SQL injection.

Mitigation Strategies:

  • Immediate Update: Upgrade to Feedzy version 4.4.3, which contains the patch for this vulnerability.
  • Review User Permissions: Limit user permissions to the minimum necessary and regularly audit user roles.
  • Monitor for Suspicious Activity: Keep an eye on database access logs and website activity for signs of exploitation.

Recommendations:

WordPress website administrators using the RSS Aggregator by Feedzy plugin should update to version 4.4.3 immediately to address this critical vulnerability. Additionally, it is advisable to review and adjust user permissions and monitor website activity to prevent potential exploitation.

Stay safe and informed,

OP Innovate Research Team.

Resources highlights

Node2Shell (CVE-2026-111497) Under Active Exploitation as Critical Brotli Flaw Extends Beyond Node.js

A critical vulnerability in Google's Brotli decompression library is drawing increasing attention from attackers, with exploitation attempts observed just days after patches became available. Tracked…

Read more >

node2shell

PHP2Shell: Critical PHP RCE Flaws Targeted in Attacks (CVE-2026-109618 & CVE-2026-109619)

Attackers are targeting two critical vulnerabilities in PHP. The vulnerabilities, collectively known as PHP2Shell are tracked as CVE-2026-109618 and CVE-2026-109619, and could allow unauthenticated attackers…

Read more >

php2shell

ConnectWise SkyKick Compromise: Attackers Hijack Trusted Microsoft 365 Applications to Access Customer Tenants

A compromised application credential belonging to ConnectWise Cloud Backup, formerly known as SkyKick, has been used in a supply chain attack targeting Microsoft 365 environments.…

Read more >

skykick_op

Ivanti CVE-2026-104935: Three Zero-Days Chained for Root Access in Active Attacks

Ivanti has released emergency security updates after attackers exploited a chain of three zero-day vulnerabilities in its Connect Secure VPN appliances to gain root-level access…

Read more >

ivanti_cve-2026-104935

GitLab CVE-2026-97229: Critical 10.0 RCE Vulnerability Puts CI/CD Servers at Risk

GitLab has released emergency security updates to address a critical vulnerability that could allow attackers to execute arbitrary code on affected servers. Tracked as CVE-2026-97229,…

Read more >

gitlab_cve-2026-97229

SonicWall CVE-2026-102255: Critical SMA1000 Vulnerability Targeted in Active Attacks

Attackers are targeting a critical vulnerability in SonicWall Secure Mobile Access (SMA) 1000 appliances, just days after the company released security updates to address the…

Read more >

sonicwall_cve-2026-102255
Under Cyber Attack?

Fill out the form and we will contact you immediately.